January 25, 2022, 03:32:39 AM

Poll

Is it working for you?

Yes
18 (64.3%)
No
10 (35.7%)

Total Members Voted: 28

Author Topic: How to view your own replays (with full instructions on how to install the game)  (Read 20704 times)

StarALaMod

  • New Member
  • *
  • Posts: 12
    • View Profile
I just gave u plus one karma so you better hurry up and release that AI pack XD

chetjan

  • Sr. Member
  • ****
  • Posts: 164
    • View Profile
I am hoping to work with Varesh it get a easier launcher that will automatically do what is in this thread, and therefore allow you to easily watch your own replays. Be patient guys.

r3ddrag0nx

  • Resident
  • **
  • Posts: 22
    • View Profile
the sc2replayinstaller.zip link must be down doesnt seem to work. can someone host all files from accescible.com?
 
btw, how do we view multiplayer replays from other players? i ididnt kno this was to view our own vs ai but thats not as useful imo
« Last Edit: March 01, 2010, 09:54:41 PM by r3ddrag0nx »

chetjan

  • Sr. Member
  • ****
  • Posts: 164
    • View Profile
For other players just post the original AI back in the starcraft folder and it should work. (for people with the actual beta player vs player). Otherwise for others using the crack, to see there builds and such you just need the version of the AI they used copied. Will update the links soon.

Telsiph

  • New Member
  • *
  • Posts: 2
    • View Profile
Greetings,

Got it working, added karma!
« Last Edit: March 02, 2010, 10:03:04 PM by Telsiph »

chetjan

  • Sr. Member
  • ****
  • Posts: 164
    • View Profile
*Edit @Telsiph you literally edited your post 30 seconds before I responded. Glad you got it working and thanks for the karma :)

Giz

  • Member
  • ***
  • Posts: 60
    • View Profile
i did all that, I could watch the replays that were in the replay installer file (replays by others)


but when I went into the game and played, exited, came back try to launch it with lazytown (and also tried to launch it inside the sc2 itself) I get error: Unable to open map.....


I do not know what is wrong but for some reasons I cannot watch my own games vs AI....

ThaKissick

  • New Member
  • *
  • Posts: 5
    • View Profile
Giz,

The replays you are watching of others? Are they replays you have downloaded from a website? Like official replays?

If so, you can watch these only because you have a Cache folder that matches these.

If you want to watch replays of yourself playing AI, you need to determine what "version" of the Cache folder matches your AI map. There are several versions of the Cache folder out there, you just have to experiment and find the correct one to place in the Application Data\Blizzard Entertainment\Battle.net directory.

chetjan

  • Sr. Member
  • ****
  • Posts: 164
    • View Profile
Thank you ThaKissick. I believe that is exactly right.

gg.sc2

  • Member
  • ***
  • Posts: 62
    • View Profile
Okay I am also having problems trying to watch my own replays. I added my maps into the 00 > 11 folder inside the cache folder in Documents and Settings > user > appdata > local > blizzard entertainment > battle.net. I added 0011 in front of each map's file name as well. I use lazylauncher to load these specific maps and play a game but when I try to load any replay from the Recent folder, I get an "Unable to open map" error. I'm using the same base.SC2Data file as the one I played with, everything is the same, I just tried loading the replay, but the issue remains. If it was a cache problem, I assume I'd get the **TEMP*** error, but it's not that. Does anybody have a solution to this? Perhaps I'm loading my maps from the wrong place?
« Last Edit: March 03, 2010, 10:11:54 PM by gg.sc2 »

ThaKissick

  • New Member
  • *
  • Posts: 5
    • View Profile
Okay I am also having problems trying to watch my own replays. I added my maps into the 00 > 11 folder inside the cache folder in Documents and Settings > user > appdata > local > blizzard entertainment > battle.net. I added 0011 in front of each map's file name as well. I use lazylauncher to load these specific maps and play a game but when I try to load any replay from the Recent folder, I get an "Unable to open map" error. I'm using the same base.SC2Data file as the one I played with, everything is the same, I just tried loading the replay, but the issue remains. If it was a cache problem, I assume I'd get the **TEMP*** error, but it's not that. Does anybody have a solution to this? Perhaps I'm loading my maps from the wrong place?


You seem to have done everything right here, the only thing I feel worth mentioning is make sure you run/open the map file from the Cache folder... when LazyLaunch asks you to browse to a location, browse to the map that is actually inside the Cache\00\11 folder. When I run maps from inside Cache I can watch the replays no problem with no, Unable to load map error.

gg.sc2

  • Member
  • ***
  • Posts: 62
    • View Profile

You seem to have done everything right here, the only thing I feel worth mentioning is make sure you run/open the map file from the Cache folder... when LazyLaunch asks you to browse to a location, browse to the map that is actually inside the Cache\00\11 folder. When I run maps from inside Cache I can watch the replays no problem with no, Unable to load map error.

I do load my maps from the cache folder in lazylauncher, 0011(2) - blahblah. Still get the error though. Maybe its cuz of patch 2 or something.

Skygrinder

  • The Coolest
  • Member
  • ***
  • Posts: 43
  • 1a2a3a
    • View Profile
Okay I am also having problems trying to watch my own replays. I added my maps into the 00 > 11 folder inside the cache folder in Documents and Settings > user > appdata > local > blizzard entertainment > battle.net. I added 0011 in front of each map's file name as well. I use lazylauncher to load these specific maps and play a game but when I try to load any replay from the Recent folder, I get an "Unable to open map" error. I'm using the same base.SC2Data file as the one I played with, everything is the same, I just tried loading the replay, but the issue remains. If it was a cache problem, I assume I'd get the **TEMP*** error, but it's not that. Does anybody have a solution to this? Perhaps I'm loading my maps from the wrong place?

Yea i did all these stuff too and it doesn't work for me either.

EDIT: I got it working, i was launching the game with the ALLin1 Launcher http://darkblizz.org/Forum2/sc2-tools/starcraft-2-beta-best-allin1-crack-%28offline-mode%29/

and it didn't work, then i launched directly with lazylaunch and it did work. I thought there would be no difference since ALLin1 Launcher uses lazylaunch too...

Anyway hope that helps someone who did the same thing as me.
                                                      
« Last Edit: March 04, 2010, 03:14:08 AM by Skygrinder »
Blood for the Blood God

Giz

  • Member
  • ***
  • Posts: 60
    • View Profile
mate, try a different folder, I use to have the Unable to open map error, had all those 00\11 folders, I made a different folder 09 (I actually already had that folder in cache) and made a z7 folder in it so it be like  09\z7 - then renamed all files like 09z7Blisteringsands.sc2ma (or whatever the extention is)


and then it worked

bcboncs

  • New Member
  • *
  • Posts: 4
    • View Profile
mate, try a different folder, I use to have the Unable to open map error, had all those 00\11 folders, I made a different folder 09 (I actually already had that folder in cache) and made a z7 folder in it so it be like  09\z7 - then renamed all files like 09z7Blisteringsands.sc2ma (or whatever the extention is)


and then it worked


First post. I just wanted to thank everyone that contributed to Blizzard's non-negotiable open source SC2 Beta. Giz, I have the identical problem that you're having. However, I played a game with lazylauncher pointing to a map that is in a downloaded folder somewhere instead of the cache folder. Now like you, I can replace my BaseSC2 file and there aren't any problems watching the actual beta vs beta players going head-to-head. However, when trying to view a replay that is in my Recent replays folder (either through cracked play as guest UI or lazylaunch), I receive the 'unable to open map' message.


It seems like the replays are trying to point to a map in the cache folder with the odd map names regardless of what map was actually selected when playing the game (lazylaunch's 1v1 LT). It must wrap up the original file within the replay, then attempt to find that to 'open the map' in the cache folder directory? I've attempted to rename my downloaded Lost Temple AI map to the same file name of the 9666 lost temple cache file and open the replay, but again no dice. I've put the BaseSC2 file as the default and the one that I hosted the game on when playing against the AI, no dice.


I feel like I'm losing track of what I'm altering... I am just impressed that I was able to defeat the waves of Zerg rushing you on Chinese x5 so I wanted to see it and have proof! :( I'd also like to see how I progress with my skill throughout Beta as well as my APM.


Anyone have any ideas?
Thx

 

SimplePortal 2.3.5 © 2008-2012, SimplePortal