Author Topic: Server Emulation Support Thread. (Newbs post here)  (Read 43774 times)

Cencio

  • Resident
  • **
  • Posts: 23
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #135 on: October 28, 2011, 08:34:01 AM »
NOW, i get this:

Quote
[Fatal] [MPQPatchChain]: Required patch-chain version 7447 is not satified <found version: 0>.


SWRogue

  • New Member
  • *
  • Posts: 6
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #136 on: October 28, 2011, 06:30:16 PM »
After copying all the MPQs to the Assets folder I still get nowhere, with the newest build I get stuck at the Loading Screen after making a character.

Phanamine

  • Archangel
  • D3 Section Chief
  • Member
  • *
  • Posts: 83
  • Farnham The Drunk: Egch! You drink WATER!?
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #137 on: October 28, 2011, 08:31:43 PM »
After copying all the MPQs to the Assets folder I still get nowhere, with the newest build I get stuck at the Loading Screen after making a character.

 Well now that the new commit has been implamented I also now get stuck at the loading screen.. Not sure what they are wanting us to test..  :'(
I can see what you see not,
Vision milky then eyes rot.
When you turn they will be gone,
Whispering their hidden song.
Then you see what cannot be,
Shadows move where light should be.
Out of darkness, out of mind,
Cast down into the halls of the blind

VALVe DnB

  • Resident
  • **
  • Posts: 19
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #138 on: October 29, 2011, 06:07:31 PM »
I was having the same problem - you just need to copy "everything" from Data_d3\PC\MPQs  to Mpq folder in mooege then start mooege exe and wait till loads all in mooege window and start the game!

Marcin

  • New Member
  • *
  • Posts: 2
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #139 on: October 29, 2011, 06:55:43 PM »
Hi,
I believe I've got same problem,
Quote
[30.10.2011 00:48:48.203] [ Info] [Program]: mooege v0.1.4319.42443 warming-up..
[30.10.2011 00:48:48.609] [ Info] [Program]: Item database loaded with a total of 1006 item definitions
[30.10.2011 00:48:48.609] [ Info] [MPQStorage]: Initializing MPQ storage..
[30.10.2011 00:48:48.656] [ Info] [MPQPatchChain]: Adding patch file: /base/d3-update-base-7170.MPQ
[30.10.2011 00:48:48.656] [ Info] [MPQPatchChain]: Adding patch file: /base/d3-update-base-7200.MPQ
[30.10.2011 00:48:48.656] [ Info] [MPQPatchChain]: Adding patch file: /base/d3-update-base-7318.MPQ
[30.10.2011 00:48:48.656] [ Info] [MPQPatchChain]: Adding patch file: /base/d3-update-base-7338.MPQ
[30.10.2011 00:48:48.656] [ Info] [MPQPatchChain]: Adding patch file: /base/d3-update-base-7447.MPQ
[30.10.2011 00:48:49.500] [Fatal] [Program]: Mooege terminating because of unhandled exception. - [Exception] System.TypeInitializationException: The type initializer for 'Mooege.Common.MPQ.MPQStorage' threw an exception. ---> System.IO.InvalidDataException: Found invalid data while decoding.
   at CrystalMpq.MpqFileStream.ApplyPatch(PatchInfoHeader patchInfoHeader, Stream baseStream)
   at CrystalMpq.MpqFileStream..ctor(MpqFile file, Stream baseStream)
   at CrystalMpq.Utility.MpqFileSystem.ResolveBaseFile(Object sender, ResolveStreamEventArgs e)
   at CrystalMpq.MpqArchive.ResolveBaseFileInternal(MpqFile file)
   at CrystalMpq.MpqFileStream..ctor(MpqFile file, Stream baseStream)
   at CrystalMpq.MpqFile.Open()
   at Mooege.Common.MPQ.Data.LoadCatalog() in C:\Documents and Settings\R. Zombie\Pulpit\mooege-mooege-a245291\mooege-mooege-a245291\src\Mooege\Common\MPQ\Data.cs:line 71
   at Mooege.Common.MPQ.Data.Init() in C:\Documents and Settings\R. Zombie\Pulpit\mooege-mooege-a245291\mooege-mooege-a245291\src\Mooege\Common\MPQ\Data.cs:line 42
   at Mooege.Common.MPQ.MPQStorage..cctor() in C:\Documents and Settings\R. Zombie\Pulpit\mooege-mooege-a245291\mooege-mooege-a245291\src\Mooege\Common\MPQ\MPQStorage.cs:line 46
   --- End of inner exception stack trace ---
   at Mooege.Common.MPQ.MPQStorage.Init()
   at Mooege.Program.Main(String[] args) in C:\Documents and Settings\R. Zombie\Pulpit\mooege-mooege-a245291\mooege-mooege-a245291\src\Mooege\Program.cs:line 58
but as far as I see *everything* (total:  2,88 GB from /PC/MPQ) is in assetts.

VALVe DnB

  • Resident
  • **
  • Posts: 19
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #140 on: October 29, 2011, 07:26:21 PM »
Everything from D3_Data\MPQs is exact 3.20 GB(all the files and folders) - you need to copy all and put it to Mooege\Assets\MPQ then run mooege(wait till it loads !) and run Diablo 3
Btw there are some BIG changes
Artisans
Some NPCs
Interaction with npc's - at least some of them
Working waypoints and doors(dungeons and cellars etc)
some objects...
I think soon we will have almost everything!

Marcin

  • New Member
  • *
  • Posts: 2
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #141 on: October 29, 2011, 07:34:56 PM »
Hm, my installation is just 2,88. Have to investigate this. Thanks.

Cencio

  • Resident
  • **
  • Posts: 23
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #142 on: October 29, 2011, 08:51:23 PM »
Everything from D3_Data\MPQs is exact 3.20 GB(all the files and folders) - you need to copy all and put it to Mooege\Assets\MPQ then run mooege(wait till it loads !) and run Diablo 3
Btw there are some BIG changes
Artisans
Some NPCs
Interaction with npc's - at least some of them
Working waypoints and doors(dungeons and cellars etc)
some objects...
I think soon we will have almost everything!

This is an answer. Now all works perfect!. Thanks.

Sheetso

  • Resident
  • **
  • Posts: 29
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #143 on: October 29, 2011, 09:09:40 PM »
Ok now it runs but with some kind of "speedhack".... ┬┤did i make something wrong or is there a way to change it to "normal runspeed"? o.O

thx :D

katarax

  • New Member
  • *
  • Posts: 4
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #144 on: October 29, 2011, 09:14:57 PM »
Im gettin an error code 10006 when i try to spawn monsters, or even talk in the chat box. plus im not seeing any mobs or npcs

SWRogue

  • New Member
  • *
  • Posts: 6
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #145 on: October 29, 2011, 09:36:12 PM »
Ok I have copied all 3.2g over to the correct folder but should it take more then say 5 min to get past the loading screen as it would never take long before.
I still get the : [Fatal] [MPQPatchChain]: Cannot find base MPQ file: CoreData.mpq
I'm downloading / reinstalling to see if that fixes it.

Sheetso

  • Resident
  • **
  • Posts: 29
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #146 on: October 30, 2011, 01:11:53 PM »
Ok I have copied all 3.2g over to the correct folder but should it take more then say 5 min to get past the loading screen as it would never take long before.
I still get the : [Fatal] [MPQPatchChain]: Cannot find base MPQ file: CoreData.mpq
I'm downloading / reinstalling to see if that fixes it.

You must copy the MPQ Files to Mooege\src\Mooege\bin\Release\Assets\MPQ

hope it helps....

AlphaT

  • New Member
  • *
  • Posts: 4
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #147 on: November 05, 2011, 03:58:44 AM »
OMG, WTF?! I loadet mooege 3 weeks ago, all worked right. Now i download and try to run the last build, second day, and get some stupid errors... ???






Than run .exe  ???



Do you have some ideas?   ::)
« Last Edit: November 05, 2011, 04:02:49 AM by AlphaT »

Espionage724

  • Resident
  • **
  • Posts: 30
    • View Profile
    • Realm of Espionage
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #148 on: November 05, 2011, 04:49:24 AM »
OMG, WTF?! I loadet mooege 3 weeks ago, all worked right. Now i download and try to run the last build, second day, and get some stupid errors... ???






Than run .exe  ???



Do you have some ideas?   ::)

1. Those aren't errors, their warnings. If they were errors, you wouldn't of been able to compile :p

2. You need to copy D3 mpq's to the MPQ folder in Mooege's directory somewhere (it's not really "that" hard, I figured that out without reading anything :p). Can't really say which folders exactly though, I'm not in front of my main computer atm :/ Good luck

AlphaT

  • New Member
  • *
  • Posts: 4
    • View Profile
Re: Server Emulation Support Thread. (Newbs post here)
« Reply #149 on: November 05, 2011, 06:16:55 AM »

1. Those aren't errors, their warnings. If they were errors, you wouldn't of been able to compile :p

2. You need to copy D3 mpq's to the MPQ folder in Mooege's directory somewhere (it's not really "that" hard, I figured that out without reading anything :p). Can't really say which folders exactly though, I'm not in front of my main computer atm :/ Good luck

thk you,  but now i have this O_o



 

SimplePortal 2.3.5 © 2008-2012, SimplePortal